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Video Tutorials for Setting up Theme 
Use following password to view videos; 
PIXFILLDEMOVIDEOS 

 

How to Install Theme & Import Dummy Data 

 

How to Install Required Plugins 

 

 
 

 

 

 

 

 

 

 

 

 

https://vimeo.com/97525172
https://vimeo.com/97525409
https://vimeo.com/97525172
https://vimeo.com/97525409


How to use page Builder 
 

 
How to Use theme Options  

 

How to Add gallery Slider 

 

  

 

https://vimeo.com/97535826
https://vimeo.com/97535826
https://vimeo.com/97526882
https://vimeo.com/97526882
https://vimeo.com/97525171
https://vimeo.com/97525171


 

 

 

HOW TO INSTALL WORDPRESS  
  
This is a thorough step-by-step tutorial that will show you how to install WordPress on your 
own server.  

  
Assuming you already have a domain name and web hosting account, you’re ready to go 
ahead.  
  

1. Download WordPress  

  
The very first thing you’ll want to do is download a copy of the software. So, go to the  
WordPress site here, and look for the link that says “DOWNLOAD.ZIP.” You should see it on 
the right side of the page with a dark blue background. When you see the link, click on it, and 
save the file to your desktop so it’s easy to find going forward.  
  

2. Unzip the Folder  

  
After you download the program, you’ll need to unzip the files into their own folder on your 
desktop. Most computers have a built-in zip/unzip application when you buy them, and if 
you’re not sure about your system, right-click on the file you just downloaded, and look for 
the menu option that says “Extract All …” Select that option if you see it. If you don’t have an 
unzip feature already installed, you can download a free program called  Stuffit Expander (for 
PC or Mac).  
  

3. Set UP Your FTP Program  

  
FTP stands for File Transfer Protocol, and an FTP program will allow you to copy files from 
your own computer to your web hosting account. There are many FTP programs available, 
and one of the more popular ones is free program called FileZilla. You can download it  here.  
  

4. Get Your FTP Access Information  

  
You’ll need to enter this information into your FTP program to access and upload files to your web 
host. Specifically, you’ll need to enter the domain name, username and password for your FTP 
account. You can get this information from your web host if you don’t have it already.  
  

5. Set Up Your MySQL Database With Your Web Host  

  
This isn’t as scary as it may sound. Well, not if you have a good web host. You can usually find 
a link in your web hosting control panel to set up a MySQL database. Once the database is set 
up, you’ll need the database name, database password, database username and database 
hostname The hostname is usually “localhost,” but not always, so check with your web host 
to be sure. If you use Hostgator, it is localhost.  
6 . Enter Your Database Information into Your Config File  

http://wordpress.org/download/
http://wordpress.org/download/
http://wordpress.org/download/
http://www.stuffit.com/
http://www.stuffit.com/
http://www.stuffit.com/
http://filezilla-project.org/
http://filezilla-project.org/
http://filezilla-project.org/


Remember when you downloaded and unzipped the WordPress program on your computers 
desktop? Open that folder, and you’ll see another folder labeled “WordPress.” Open that 
folder, and find a file named wp-config-sample. Open this file in a text editor such as Notepad 
or Wordpad. When you open the file you’ll see some text, much of which looks like gibberish, 
but it’s not. Look specifically for the lines that read:  
  
  
  
  
// ** MySQL settings - You can get this info from your web host ** //  

  
/** the name of the database for WordPress */ 
define('DB_NAME', 'putyourdbnamehere');  

  

/** MySQL database username */ define('DB_USER', 

'usernamehere');  

  
/** MySQL database password */ define('DB_PASSWORD', 
'yourpasswordhere');  

  
/** MySQL hostname */  

define('DB_HOST', 'localhost');  
  
  
  
  
This is the place to enter the database information you saved from the previous step. So 
whatever the database name is, enter that information in place of ‘putyourdbnamehere.’ Just 
be sure to leave the ‘ marks before and after as it appears above. Do the same for the 
DB_USER, DB_PASSWORD and DB_HOST. When you’re done, save the file, but save it as 
wpconfig.php rather than wp-config-sample.  
  

7. Upload WordPress to Your Server  

  
Okay. We’re in the homestretch. The next thing you want to do is upload the entire program 
from your computer to you host’s server. So, first, open your FTP program and connect to 
your host’s server. Back in step 5, you tracked down your FTP information. If you haven’t 
already entered it into your FTP program, go ahead and do that now. Again, you’ll need to 
enter you domain name, your username and your password. After you enter the information, 
go ahead and connect to your host’s server.  

  
At this point, you’ll need to make a decision about where you’ll place the program. You can 
put it in – either – the root directory of your host server or a sub-directory. Personally, I place 
mine in a subdirectory because I run several different websites on the same server, and it just 
makes things a lot easier by keeping them separate. After you make your decision, go ahead 
and upload all the files and directories located in the WordPress folder you unzipped to you 
desktop, excluding the folder itself.  
  



  

8 . Run the Install Script  

1. If you installed WordPress in the root directory of your server, open your web browser 
and type the following: http://www.mydomain.com/wp-admin/install.php (replace 
“mydomain.com” with your own domain name).   

  

2. If you installed WordPress in a sub-directory, open your web browser and type the 
following: http://www.mydomain.com/subdirectory/wp-admin/install.php (replace 
“mydomain.com” with your own domain name and “subdirectory” with the name of 
the sub-directory you created).   

  
After you go to this page, WordPress will do the rest. Just follow the onscreen directions, and 
then you’ll be all done.  
  
  
  
   



UPLOAD AND INSTALL WORDPRESS THEME-  
  
Once the download is complete from theme forest, extract the archive. The theme will be inside the 
main folder with same title. This inside folder needs to be picked for installation, upload it and activate 
by using any of these method.  
  
There are two ways to install a WordPress theme – manually with an FTP client, or automatically 

through the upload feature in the WordPress dashboard. Below you will see both options.  
  

Installing a Theme through the WordPress Dashboard  

  
1. Log in to your WordPress dashboard and go to Appearance → Themes. At the top of  the page, 

click the tab “Install Themes.”   

2. Just below the headline, you will see a link that says “Upload” – click that.   

  

3. Click the browse button and find the theme.zip file from your local machine and then click the 

“Install Now” button.   

  

Installing Theme with an FTP Client  

  

  
Download the theme zip file to your local machine and unzip it.  
  

1. Log onto your server through an FTP client, and find your site’s wp-content/themes directory. 

You will want to transfer the entire theme folder to that directory.   

  

2. Log in to your WordPress dashboard, and go to Appearance → Themes. There you will see 
screenshots of the themes that are available for you to use. Click on the theme title  

(or theme screenshot) for the theme you wish to activate. A preview of the theme will be   

3. shown, and then you can click the Activate link in the top right of the preview window 



HOW TO USE THE XML FILE TO IMPORT THE DEMO SITE’S CONTENT-  
  
To import from a WordPress export file into your blog follow these steps.  
  

1. Log into your site as an administrator.   

2. Make sure you activated your new theme before proceeding.   

3. Go to Tools → Import   

4. Choose “WordPress” from the list.   

  

5. Choose the sample content file and upload it. Remember; do not select a .zip or unzipped folder. 

The demo content is always a file with .xml extension, for example samplecontent.xml.   

  

6. You will be asked to map the authors in this export file to users on the blog. For each author, you 
may choose to map to an existing user on the blog or to create a new user.   

  

7. You will then have the choice to import attachments, so click on the “Download and import file 

attachments” box.   

  

8. Please be patient while WordPress imports all the content. Posts, Pages, Projects, and Menus are 

imported. You will need to assign the menu a theme location & you’ll need to configure widgets. 

This is a limitation of WordPress’ import system.  

  

  

WORDPRESS MENU CREATION-  
  
Theme works like Word Press default themes and does not load any of its menus by default. Menu need 
to be created once the dummy data is imported. After theme activation, follow the procedure described 

below and shown in the image below to create new menu;  
  
1. Go to Appearance   

2. Click on the Menu under appearance section   

3. Put the name of Menu, whatever you like   

4. Create Menu, it’s done   

   

  

HOW TO SET HOME PAGE  
To set a page as home page, first you need to create a page with the name of “HOME” or any of your 

choice. To do this, GO TO Admin Panel > Pages > Add new Page  



NOTE:  

GO TO > Admin Panel > settings > Readings >  (see screen shot) 

 

Select the page as static which you want to make as home page.   

Following customizations are also possible for home page;  

i. When you add a new page as your home page, you can drag & drop any element you want to 

show on home page from Page builder like Fixture, gallery, team etc.  

To set up home page slider, Go to Admin Panel > Appearance > PX Theme options > Home page settings 

> Choose Slider Category from post category (Please see screen) 



 

 

ii. To show announcements Go to Admin Panel > Appearance > PX Theme options > Home page 

settings > Choose announcement title > Breaking News Category. 

  

HOW TO SET UP NEWS AND BLOG PAGE  
To set a News and Blog page, GO TO Admin Panel > Posts > Add new Post.   

It further allows following customizations;   

i. Create category  

ii. Select post type, post name  & featured image  

NOTE:  

You can show post on front end by clicking GO TO PAGES > Add new page > Drag Blog element for news 

and Blog from Page Builder which is in lower area of the page. Click on EDIT icon and do the following;   



i. Put Blog section title ii. Add Blog View like large, 

medium, grid, slider etc iii. Choose category iv. Select 

length of excerpt  

v. Choose featured category for 

featured post slider. No 

matter what view is like large, 

medium etc.  

It will show in top of the page in slider and depends upon number of posts.   

vi. Show/ Hide pagination vii. 

Limit number of post per page  

HOW TO ADD REVIEWS 
The evolution of online feedback and commenting has come a long way; from the old school guestbook 
to forum and feedback form, and from native platform-dependent commenting systems to today’s Chimp 
Studio’s commenting systems. It offers to get Reviews/Ratting of the client about the items you offer 

them. 

 

It helps understanding the standing of the items and adds valuable information for up-gradation. Ratings 

can be obtained in Star/Percentage/Points form. 

 

Pixfill theme comes with option to add Review/Ratting systems and categorize according to their nature. 
To create a Review go to wp-admin > Posts > Add new Posts > Click on Add Review > Select Category> 

Publish the post.   

 

SETTING UP REVIEW PAGE:  
To set up review page, Go to Page Builder > Add New Page > Click on Blog Page Element from Page 

Builder > Select Blog View (like slider, grid v1, grid v2 etc) > Select Category > Publish the Page. All 

Done!! 

  

LANGUAGE & TRANSLATIONS-  
  
GO TO APPEARANCE > THEME OPTIONS > TRANSLATION  

  
Being global needs you to display your message in regional languages of targeted clients. This theme offers 
to upload new desired languages. To upload MO file of desired language, Go to Appearance > Theme 

Options > Translation to select or edit also for all strings of theme can be translated.  

  

  

 WPML: 
 



Along with other stunning features, Pixfill theme comes with WPML plugin support. It is compatible with 

WPML which makes it easy to build multilingual sites and run them. It’s powerful enough for corporate 

sites, yet simple for blogs. With WPML you can translate pages, posts, custom types, taxonomy, menus 

and even the theme’s texts. 

Where to buy and download: 

You can buy WPML plug-in by clicking at www.wpml.org/purchase/. It will guide you through the 

process. 

How to Download and install plugin: 

1. Once you buy the plug-in, it gets downloaded on your computer. Unzip it and pick the main plug-in 

folder. 

2. Go to WP root folder > WP-content > Plugin and the paste the plugin folder you picked from unzipped 

folder. 

3. To activate the installed plugin, Go to WP-admin > plug-in section & activate the plugin. 

Where we can show language switcher widget in theme 

In the theme, this language switcher widget can be shown in following areas; 

1. In top Menu OR Main Menu. 

2. In Side Bars. 

3. In the Footer. 

4. If you wish to show it anywhere in the theme, use the following PHP code in the theme file; 

<?php do_action(‘icl_language_selector’); ?> 

Options for localizing theme 

WPML allows localizing themes in two ways: 

1. The traditional .mo files (when you already get that with the theme). 

2. Translate the theme’s texts directly from WPML 

For further assistance, visit wpml.org/documentation/getting-started-guide/theme-localization/. 

 

Attention! In order to translate all strings in different languages through WPML you need to turn ON 

translation switcher. Go to Appearance > theme options > general settings > other settings and turn on 

the translation switcher. 

 

Adds Banner 
Adds Banner is another stunning feature of PixFill theme that enables you to add a banner and place 

advertisement is it. It allows following customizations; 

i. Use Google add sense code 

ii. Use static image and link it any where 

iii. Auto generated short codes that can be placed anywhere like in widgets, page, post etc 

You can add banner from Theme Options > Banner Settings > Adds Banner. That’s all!! 

See Screen Shot for further clarity. 



 

After Adding Banner, Please copy short code and paste it anywhere you want your banner to show up 

like widget, header, footer, content area etc! Follow screen shot given below for further 

reference.  



 

 

  

 



Woo commerce 
 

Woo Commerce is an open source e-commerce plugin for WordPress. Woo Commerce is designed for 

the small to medium-sized online merchant using WordPress. 

 

There are two Woo Commerce installation options: Automatic or Manual. 

 

Automatic installation 

Automatic installation is the easiest option as WordPress handles the file transfers itself and you don’t 

even need to leave your web browser. To do an automatic install of Woo Commerce log in to your 

WordPress admin panel and go to: Plugins > Add New. 

 

In the search field type “Woo Commerce” and click Search Plugins. Once you’ve found the plugin you 

can view details about it such as the point release, rating and description? Most importantly of course, 

you can install it by simply clicking Install Now. After clicking that link you will be asked if you’re sure you 

want to install the plugin. Click “yes” and WordPress will automatically complete the installation. 

 

It’s possible at this stage that you will be taken to a page requesting the FTP details of your webserver. 

This will be the case if you’ve not installed a plugin on this particular installation of WordPress before. If 

so, simply fill in your details to complete the installation. 

 

Manual Installation 

The manual installation involves downloading the plugin and uploading it to your webserver via your 

favorite FTP application. 

 

Download the plugin to your computer. (You can download from http://wordpress.com/plugin) 

Unzip the file. 

Using an FTP program, or your hosting control panel, upload the unzipped plugin folder to your 

WordPress installation’s wp-content/plugins directory. 

Activate the plugin from the Plugins menu within the WordPress admin. 

After you’ve installed and activated the plugin, be sure to select ‘Install Woo Commerce Pages‘ to get 

started. 

 

BB PRESS Forum 
bbPress is forum software with a twist from the creators of WordPress. Easily setup discussion forums 
inside your WordPress.org powered site. 

To use bbpress, just install bbpress plugin and start enjoying it.  

SUPPER SUPPORT -  
  



If you have any questions related to setting up the theme that are not covered in this documentation or 

if you encounter any technical bugs, please submit a ticket at the  Themes Support Centre. Please note 
that this theme is sold "as-is" and any additional custom modifications you would like to make to the 

theme are your responsibility.  
  
  

SOURCES AND CREDITS -  
I've used the following images, icons or other files as listed.  
  

1. Icons used : entypo and font awesome   

2. images in demo from unsplash and created by us:  http://unsplash.com/   

3. http://pupunzi.open-lab.com/mb-jquery-components/mb-gallery/   

  
  
  
Once again, thank you so much for purchasing this theme. As I said at the beginning, I'd be glad to help 

you if you have any questions relating to this theme. No guarantees, but I'll do my best to assist. If you 

have a more general question relating to the themes on ThemeForest, you might consider visiting the 

forums and asking your question in the "Item Discussion" section.  
 

 

http://themeforest.net/user/pixfill/
http://themeforest.net/user/pixfill/
http://themeforest.net/user/pixfill/
http://unsplash.com/
http://unsplash.com/
http://unsplash.com/

